4aa4d9fa74
* Rebuild source to have -X .la
79 lines
1.8 KiB
Makefile
Executable File
79 lines
1.8 KiB
Makefile
Executable File
#!/usr/bin/make -f
|
|
|
|
include /usr/share/quilt/quilt.make
|
|
|
|
DPKG_EXPORT_BUILDFLAGS = 1
|
|
include /usr/share/dpkg/buildflags.mk
|
|
|
|
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
|
|
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
|
|
|
|
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
|
|
CFLAGS += -O0
|
|
else
|
|
CFLAGS += -O2
|
|
endif
|
|
|
|
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
|
|
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
|
|
MAKEFLAGS += -j$(NUMJOBS)
|
|
endif
|
|
|
|
configure: configure-stamp
|
|
configure-stamp: $(QUILT_STAMPFN)
|
|
dh_testdir
|
|
autoreconf -i
|
|
LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)" \
|
|
./configure --prefix=/usr \
|
|
--host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE)
|
|
touch "$@"
|
|
|
|
build: build-stamp
|
|
build-stamp: configure
|
|
dh_testdir
|
|
$(MAKE)
|
|
touch $@
|
|
|
|
pre-clean:
|
|
[ ! -f Makefile ] || $(MAKE) maintainer-clean
|
|
|
|
clean: pre-clean unpatch
|
|
dh_testdir
|
|
dh_testroot
|
|
rm -f build-stamp configure-stamp
|
|
find . -name "Makefile.in" | xargs rm -f
|
|
rm -f configure ltmain.sh aclocal.m4 config.sub config.guess depcomp install-sh missing
|
|
dh_clean
|
|
|
|
install: build
|
|
dh_testdir
|
|
dh_testroot
|
|
dh_prep
|
|
$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp/
|
|
mkdir -p debian/libplib1/usr/share/lintian/overrides/
|
|
cp -a debian/libplib1.lintian-overrides \
|
|
debian/libplib1/usr/share/lintian/overrides/libplib1
|
|
|
|
binary-indep: build install
|
|
|
|
binary-arch: build install
|
|
dh_testdir
|
|
dh_testroot
|
|
dh_installdirs
|
|
dh_installdocs
|
|
dh_install -X.la --fail-missing
|
|
dh_installchangelogs ChangeLog
|
|
dh_link
|
|
dh_strip
|
|
dh_compress
|
|
dh_fixperms
|
|
dh_makeshlibs -V 'libplib1 (>= 1.8.5-1)'
|
|
dh_shlibdeps
|
|
dh_installdeb
|
|
dh_gencontrol
|
|
dh_md5sums
|
|
dh_builddeb
|
|
|
|
binary: binary-indep binary-arch
|
|
.PHONY: build clean binary-indep binary-arch binary install patch unpatch pre-clean configure
|